All Systems Operational
NewCropRx Operational
90 days ago
99.99 % uptime
Today
NewCropRX - Healthcheck (v1) Operational
90 days ago
100.0 % uptime
Today
NewCropRX - Web Service Operational
90 days ago
100.0 % uptime
Today
NewCropRX - Clinical Messaging Service Operational
90 days ago
100.0 % uptime
Today
Surescripts Services (Surescripts) Operational
90 days ago
100.0 % uptime
Today
EPCS Prescription Service (Exostar) Operational
90 days ago
100.0 % uptime
Today
EPCS Registration (Exostar Identity Management) Operational
90 days ago
99.96 % uptime
Today
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
Scheduled Maintenance
We will be updating the system with the latest software. We do not expect any downtime or interruption of service. Please see our knowledgebase for release information where applicable. (https://support.newcroprx.com/hc/en-us/categories/360006370512-UX2)
Posted on Feb 10, 08:44 EST
NewCrop Partners,

We are completing our project to ensure a robust and secure environment for client data. To this end, we will be enforcing the use of https and TLS 1.2 encryption of all traffic beginning August 29th, 2022 and will require all partner systems to connect with modern security protocols: https and TLS 1.2. We first notified you of our intention to adhere to these protocols in November 2020.

As it is not unusual that partner systems are sending us PHI, it is imperative that https always be used for these transactions. We will be locking this down for your security. Please review your API calls to NewCropRx and confirm that they all utilize https.

We will only support TLS 1.2 in NewCropRx preproduction from Monday August 1st.

We will disable TLS 1.0 and 1.1 in NewCropRx production and require https for 30 minutes on Tuesday August 9th at 2pm ET.

This will allow the opportunity to ensure you have made the necessary changes to your system to meet these security requirements. Your system should already be making all production calls using https. If you have clients running older browser interfaces, it is possible that they will experience issues with the TLS 1.2 requirements.

We will permanently disable TLS 1.0 and 1.1 in NewCropRx production and require https on Monday August 29th, 2022.

If you have any questions or require assistance, please contact customersupport@newcroprx.com.

Thank you,
The NewCrop Team

Posted on Jul 28, 21:55 EDT
We will be updating the system with the latest software. We do not expect any downtime or interruption of service. Please see our knowledgebase for release information where applicable. (https://support.newcroprx.com/hc/en-us/categories/360006370512-UX2)
Posted on Feb 10, 08:44 EST
We will be updating the system with the latest software. We do not expect any downtime or interruption of service. Please see our knowledgebase for release information where applicable. (https://support.newcroprx.com/hc/en-us/categories/360006370512-UX2)
Posted on Feb 10, 08:45 EST
We will be updating the system with the latest software. We do not expect any downtime or interruption of service. Please see our knowledgebase for release information where applicable. (https://support.newcroprx.com/hc/en-us/categories/360006370512-UX2)
Posted on Feb 10, 08:48 EST
We will be updating the system with the latest software. We do not expect any downtime or interruption of service. Please see our knowledgebase for release information where applicable. (https://support.newcroprx.com/hc/en-us/categories/360006370512-UX2)
Posted on Feb 10, 08:49 EST
We will be updating the system with the latest software. We do not expect any downtime or interruption of service. Please see our knowledgebase for release information where applicable. (https://support.newcroprx.com/hc/en-us/categories/360006370512-UX2)
Posted on Feb 10, 08:50 EST
We will be updating the system with the latest software. We do not expect any downtime or interruption of service. Please see our knowledgebase for release information where applicable. (https://support.newcroprx.com/hc/en-us/categories/360006370512-UX2)
Posted on Feb 10, 08:51 EST
We will be updating the system with the latest software. We do not expect any downtime or interruption of service. Please see our knowledgebase for release information where applicable. (https://support.newcroprx.com/hc/en-us/categories/360006370512-UX2)
Posted on Feb 10, 08:52 EST
We will be updating the system with the latest software. We do not expect any downtime or interruption of service. Please see our knowledgebase for release information where applicable. (https://support.newcroprx.com/hc/en-us/categories/360006370512-UX2)
Posted on Feb 10, 08:52 EST
We will be updating the system with the latest software. We do not expect any downtime or interruption of service. Please see our knowledgebase for release information where applicable. (https://support.newcroprx.com/hc/en-us/categories/360006370512-UX2)
Posted on Feb 10, 08:52 EST
NewCropRX - Healthcheck
Fetching
Past Incidents
Aug 17, 2022

No incidents reported today.

Aug 16, 2022

No incidents reported.

Aug 15, 2022

No incidents reported.

Aug 14, 2022

No incidents reported.

Aug 13, 2022

No incidents reported.

Aug 12, 2022

No incidents reported.

Aug 11, 2022

No incidents reported.

Aug 10, 2022
Completed - The scheduled maintenance has been completed.
Aug 10, 23:00 EDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Aug 10, 22:00 EDT
Scheduled - We will be updating the system with the latest software. We do not expect any downtime or interruption of service. Please see our knowledgebase for release information where applicable. (https://support.newcroprx.com/hc/en-us/categories/360006370512-UX2)
Feb 10, 08:41 EST
Aug 9, 2022
Completed - The scheduled maintenance has been completed.
Aug 9, 14:31 EDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Aug 9, 14:01 EDT
Scheduled - NewCrop Partners,

We will disable TLS 1.0 and 1.1 in NewCropRx production and require https for 30 minutes on Tuesday August 9th at 2pm ET.


We are completing our project to ensure a robust and secure environment for client data. To this end, we will be enforcing the use of https and TLS 1.2 encryption of all traffic beginning August 29th, 2022 and will require all partner systems to connect with modern security protocols: https and TLS 1.2. We first notified you of our intention to adhere to these protocols in November 2020.

As it is not unusual that partner systems are sending us PHI, it is imperative that https always be used for these transactions. We will be locking this down for your security. Please review your API calls to NewCropRx and confirm that they all utilize https.

We will only support TLS 1.2 in NewCropRx preproduction from Monday August 1st.

We will disable TLS 1.0 and 1.1 in NewCropRx production and require https for 30 minutes on Tuesday August 9th at 2pm ET.

This will allow the opportunity to ensure you have made the necessary changes to your system to meet these security requirements. Your system should already be making all production calls using https. If you have clients running older browser interfaces, it is possible that they will experience issues with the TLS 1.2 requirements.

We will permanently disable TLS 1.0 and 1.1 in NewCropRx production and require https on Monday August 29th, 2022.

If you have any questions or require assistance, please contact customersupport@newcroprx.com.

Thank you,
The NewCrop Team

Aug 9, 12:00 EDT
Aug 8, 2022

No incidents reported.

Aug 7, 2022

No incidents reported.

Aug 6, 2022

No incidents reported.

Aug 5, 2022
Resolved - This incident has been resolved.
Aug 5, 18:31 EDT
Update - We are continuing to monitor for any further issues.
Aug 5, 18:31 EDT
Monitoring - This issue appears to be resolved. We are continuing to monitor EPCS performance statistics.
Aug 5, 17:24 EDT
Investigating - We are investigating reports of failures during the EPCS registration process. Some users may encounter an error "Unable to Access Identity Proofing" while attempting to sign up for EPCS. Prescription 2FA signing does not appear to be impacted. It is recommended that users do not attempt to register for EPCS while this issue is being resolved.
Aug 5, 14:54 EDT
Aug 4, 2022

No incidents reported.

Aug 3, 2022

No incidents reported.