All Systems Operational
NewCropRx Operational
90 days ago
97.14 % uptime
Today
NewCropRx - v2 Operational
90 days ago
95.99 % uptime
Today
NewCropRX - v1 Operational
90 days ago
96.0 % uptime
Today
NewCropRX - Web Service Operational
90 days ago
96.0 % uptime
Today
NewCropRX - Clinical Messaging Service Operational
90 days ago
96.0 % uptime
Today
Surescripts Services (Surescripts) Operational
90 days ago
96.0 % uptime
Today
EPCS Prescription Service (Exostar) Operational
90 days ago
100.0 % uptime
Today
EPCS Registration (Exostar Identity Management) Operational
90 days ago
100.0 % uptime
Today
Pharmacies and PBMs Operational
90 days ago
100.0 % uptime
Today
PDMP: Bamboo Operational
90 days ago
100.0 % uptime
Today
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
NewCropRX - Healthcheck
Fetching
Past Incidents
Apr 16, 2024

No incidents reported today.

Apr 15, 2024

No incidents reported.

Apr 14, 2024

No incidents reported.

Apr 13, 2024

No incidents reported.

Apr 12, 2024

No incidents reported.

Apr 11, 2024

No incidents reported.

Apr 10, 2024
Completed - The scheduled maintenance has been completed.
Apr 10, 23:00 EDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 10, 22:00 EDT
Scheduled - We will be updating the system with the latest software version. There may be a brief interruption of service during this update.
https://support.newcroprx.com/hc/en-us/sections/4415681415316-UX2-Release-Notes

Apr 9, 12:53 EDT
Apr 9, 2024

No incidents reported.

Apr 8, 2024

No incidents reported.

Apr 7, 2024

No incidents reported.

Apr 6, 2024

No incidents reported.

Apr 5, 2024

No incidents reported.

Apr 4, 2024

No incidents reported.

Apr 3, 2024

No incidents reported.

Apr 2, 2024

No incidents reported.