Exostar EPCS Registration Issues
Incident Report for NewCropRX
Resolved
This incident has been resolved.
Posted Aug 05, 2022 - 18:31 EDT
Update
We are continuing to monitor for any further issues.
Posted Aug 05, 2022 - 18:31 EDT
Monitoring
This issue appears to be resolved. We are continuing to monitor EPCS performance statistics.
Posted Aug 05, 2022 - 17:24 EDT
Investigating
We are investigating reports of failures during the EPCS registration process. Some users may encounter an error "Unable to Access Identity Proofing" while attempting to sign up for EPCS. Prescription 2FA signing does not appear to be impacted. It is recommended that users do not attempt to register for EPCS while this issue is being resolved.
Posted Aug 05, 2022 - 14:54 EDT
This incident affected: NewCropRx (EPCS Registration (Exostar Identity Management)).