AWS has indicated that the issue has been resolved and service should now be restored fully. Please contact support should issues persist. Thank you for your patience.
Posted Oct 20, 2025 - 21:20 EDT
Update
Amazon Web Services continue to troubleshoot this matter and have made some improvements throughout the day. Several vendors are still impacted and you may continue to see issues with eligibility checks, MFA signing for controlled substances, load times and latency. This can result in issues with registration, transmission, and records retrieval.
We will continue to monitor the AWS status page and provide updates here as they come available. We will provide an update tomorrow morning if not before. We appreciate your patience.
Posted Oct 20, 2025 - 18:23 EDT
Update
Amazon is continuing to troubleshoot this matter and has narrowed down the source of the AWS connectivity issues users are experiencing worldwide with multiple platforms and services. Several third party vendors Ensora ERX integrates with have been impacted, and we are seeing sporadic issues with connectivity, controlled substance signing, calling drug history, etc.
We are continuing to monitor the situation and will continue to keep you updated as information comes available from AWS.
They are making attempts to mitigate the impact and are working towards a resolution presently. We appreciate your diligence and patience, and we will be in touch.
Posted Oct 20, 2025 - 12:10 EDT
Identified
We’re currently experiencing service disruptions due to a widespread outage affecting Amazon Web Services (AWS), which powers key components of our platform. Our team is actively monitoring the situation and staying closely aligned with AWS as they work toward resolution.
Posted Oct 20, 2025 - 09:43 EDT
This incident affected: Ensora eRx (Ensora eRx v2, NewCropRX - v1, Ensora eRx web service APIs, Ensora eRx - Clinical Messaging).