Providers should no longer experience latency or connectivity issues within eRx or while prescribing. Earlier this week, our processing queues were backlogged due to Monday’s Amazon Web Services outage. Our engineering team has since expedited this traffic, and all queues have fully caught up.
Please let us know if you encounter any remaining issues by contacting support. Thank you for your patience.
Posted Oct 22, 2025 - 15:08 EDT
Identified
A limited number of users are experiencing delays and latency. We are treating this as an urgent priority. If you have any questions, please reach out to our Support team.
Surescripts Drug History issues should be resolved. Please have providers reattempt.
Posted Oct 22, 2025 - 13:17 EDT
This incident affected: Ensora eRx (Ensora eRx v2).