IDme MFA Issue With Registration and EPCS Transmission

Incident Report for Ensora eRx

Identified

Our engineering team has identified the issue regarding ID.me MFA signing for EPCS transmission and is working on a code fix that will be implemented as soon as it is tested and ready.

We do not presently have a firm ETA on this resolution, but will be providing status updates throughout the weekend. We understand the inconvenience this causes and appreciate your patience as our teams work diligently to address this matter.
Posted Oct 24, 2025 - 17:02 EDT

Update

Our engineers are actively working to identify and reproduce the behavior causing the transmission button to appear greyed out for some ID.me users sending controlled substances. We understand how disruptive this issue can be. The issue does not affect all ID.me providers. This is being handled with the highest priority. We’ll share an update by 5 PM Eastern. Thank you for your continued patience.
Posted Oct 24, 2025 - 15:01 EDT

Update

Our engineers are continuing to investigate this and are attempting to reproduce this behavior of the transmission button being greyed out for ID.me users sending controlled substances. Our teams are triaging this with utmost priority. Not all providers using ID.me are impacted. We appreciate your patience and will have an update by 3 PM eastern.
Posted Oct 24, 2025 - 12:38 EDT

Investigating

Some providers are seeing issues when finalizing or signing EPCS scripts with ID.me MFA. Users are entering their One-Time Passcode from the app but the button remains greyed out. Not all ID.me prescribers are impacted. Our engineering team is investigating and we will update by 12:30PM EST. We appreciate your patience.
Posted Oct 24, 2025 - 10:38 EDT
This incident affects: ID.me EPCS services (EPCS Registration, EPCS Prescribing).