Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 24, 2023 - 22:00 EDT
Scheduled
We will be updating the system with the latest software version. We do not anticipate any downtime, but performance may be slowed as we rebuild an index.
Posted May 23, 2023 - 17:46 EDT
This scheduled maintenance affected: Exostar EPCS services (EPCS Registration, EPCS Prescribing), Ensora eRx (Ensora eRx v2, NewCropRX - v1, Ensora eRx web service APIs, Ensora eRx - Clinical Messaging), and Surescripts Services.