Network Connectivity
Incident Report for NewCropRX
Resolved
Surescripts has indicated that the issue has been resolved.
Posted Jul 19, 2024 - 16:54 EDT
Identified
Exostar has reported that they have resolved the issue, and EPCS registration and signing capabilities should now be available.

Surescripts is continuing to report intermittent connectivity issues. It is possible that individual pharmacies or PBMs may be impacted by the outage at this time. Please reference the Tasks page to identify failed transmissions and address any urgent prescriptions through other means through your normal processes.
Posted Jul 19, 2024 - 12:55 EDT
Update
Surescripts has indicated that most of their services have been restored. Surescripts engineers continue to work with our partners to fully restore service as quickly as possible. Surescripts continues to experience an intermittent connectivity issue for e-prescribing and clinical messaging. There is no security impact to the Surescripts network as a result of this incident.

Exostar has reported service interruption. This may result in signing prescriptions via 2FA and EPCS registrations or Identity Proofing to fail. Please reference the Tasks page to identify failed transmissions and address any urgent prescriptions through other means in the interim.

Therapy Brands systems are not impacted by either of the ongoing outages related to Microsoft Windows and the Microsoft Azure Cloud.

Please note Therapy Brands customers or business partners might be affected by this outage. Our teams are closely monitoring the situation and will provide additional update as needed.
Posted Jul 19, 2024 - 10:53 EDT
Update
The Crowdstrike-Microsoft issue has been reported to impact Exostar as well as Surescripts. This may result in signing prescriptions via 2FA to fail. Individual pharmacy chains may also be impacted and we do not yet know the scope of the issue regarding particular facilities during this widespread event. Please reference the Tasks page to identify failed transmissions and address any urgent prescriptions through other means in the interim.
Posted Jul 19, 2024 - 10:34 EDT
Investigating
Surescripts has identified an issue that is leading to intermittent connectivity. This may result in some transmissions failing. Failed prescriptions may be found on the Tasks page and may be re-sent or addressed through other means. Surescripts engineers are working to resolve the issue as quickly as possible.
Posted Jul 19, 2024 - 09:54 EDT
This incident affected: NewCropRx (NewCropRX - Clinical Messaging Service, Surescripts Services (Surescripts), EPCS Prescription Service (Exostar), EPCS Registration (Exostar Identity Management)).