The maintenance window has been extended to run between 9pm CST and 12am CST. NewCrop access may not be available during the update.
Posted Nov 13, 2024 - 22:22 EST
Update
Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Nov 13, 2024 - 22:20 EST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 13, 2024 - 22:00 EST
Scheduled
We will be performing maintenance on the system this evening at 9pm CST. The system will be unavailable during the update, which may take up to one hour.