Users Unable to MFA for EPCS

Incident Report for Ensora eRx

Resolved

Exostar has resolved the issue with Authy One-Time Passcodes and Ensora ERX has taken steps to improve system stability. Please have providers reattempt to transmit EPCS medications or access drug history. If providers are still seeing any issues, please contact support.
Posted Oct 21, 2025 - 21:37 EDT

Monitoring

Exostar has implemented a fix for the Authy/One-Time Passcode issues and providers should be able to send narcotics once again. Please test and confirm and reach out to support if you continue to see issues.

Some users have reported improvement after clearing their cache and cookies for all time and have seen improved/normal load times.

Some users are still seeing Error 504 Gateway Timeout Issues when calling Surescripts Drug History and we continue to triage this. Please reach out to Support if you continue to see issues.
Posted Oct 21, 2025 - 17:50 EDT

Update

Exostar is experiencing issues with provider pass and is working with their technology partners to resolve this. Please use the hardware token as a work around.

Please go to http://status.exostar.com for hourly updates on this.

Please have your providers who are having issues with Surescripts Drug History clear their cache and cookies for all time as that should resolve this issue.
Posted Oct 21, 2025 - 16:30 EDT

Update

We have received confirmation that clearing cache and cookies works to resolve issues with Surescripts Drug History.

We are still triaging errors with Authy Push Notifications and One-time Passcodes. We have been told that providers can use their hardware token as a workaround in the meantime. We appreciate your patience as we continue to troubleshoot this.
Posted Oct 21, 2025 - 12:40 EDT

Investigating

We are receiving reports of prescribers having issues with multi-factor authentication when signing for EPCS. Please have providers try another device or browser, clear cache and cookies for all time, and resync their MFA device(s) via Authy or ID.me by going to Admin → EPCS Device Management. If issues persist, please contact support.
Posted Oct 21, 2025 - 09:04 EDT
This incident affected: Exostar EPCS services (EPCS Registration, EPCS Prescribing), ID.me EPCS services (EPCS Registration, EPCS Prescribing), and Surescripts Services.